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1 General

The SEND/RECEIVE option package is conditional for the control of certain functions in
SIGMA AIR MANAGER in networked peer to peer communications (remote control), for
example by a PC, a workstation or a control centre. In addition, the compressed air system’s
process data are transferred to the networked communications peer via the SEND/RECEIVE
interface and are available there for visualisation or monitoring.

The transfer of control and process data between SIGMA AIR MANAGER and the
communications peer takes place via the SEND/RECEIVE communications protocol on an
Ethernet and TCP/IP with RFC 1006 (ISO transport connection, ISO on TCP connection).

The SEND/RECEIVE interface was developed by Siemens to communicate with an S5 PLC
via Ethernet and is therefore described as being S5 compatible.

To create the communications link the SEND/RECEIVE option must be enabled on SIGMA
AIR MANAGER by entering the registration code provided by KAESER. When this has been
done the SEND/RECEIVE protocol on SIGMA AIR MANAGER can be activated by selecting
the FETCH/WRITE or SEND/RECEIVE specification. The communications peer (PC) then
has write access (control data) and read access (process data) to defined, released S5 data
blocks in SIGMA AIR MANAGER.

It is especially the configuration of S5-compatible communication between SIGMA AIR
MANAGER and the SIMATIC S5 and SIMATIC S7 programmable logic controllers that is
described in detail in this document and explained with the aid of example projects.

This documentation is aimed exclusively at qualified project engineering and/or
commissioning personnel with corresponding expertise in dealing with the programmable
logic controllers and their programming described here.

2 System Requirements

2.1 SIGMA AIR MANAGER

The optional SEND/RECEIVE package can only be used with SIGMA AIR MANAGER’s
Ethernet interface and not with the RS 232 or modem link.

SEND/RECEIVE can only run on SAM 4/4, 8/4 and 16/8 models and not on the older 4/4SAM
model that is not fitted with an Ethernet interface.

A further condition for SEND/RECEIVE is that SIGMA AIR MANAGER is provided with
certain software versions. Old software must be updated.

SEND/RECEIVE can only run if SIGMA AIR MANAGER’s operating system is version 1.02
(120) or later and the KAESER software is version STEP5 v0.20 or later.
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2.2 Communications Peer

Communication with SIGMA AIR MANAGER requires the existence or implementation of the
protocol for S5-compatible communication (RFC 1006 protocol) in the communications peer.

Also, from a communications control point of view, the communications peer has to represent
an active subscriber that sends FETCH/WRITE and SEND/RECEIVE communications
commands.

The communications peer has to be networked with SIGMA AIR MANAGER via Ethernet and
operate in the same network. The standard system requirements for TCP/IP networks have
to be conformed with.

3 Limitations

Only one S5-combatible communication link can be made with a communications peer from
SIGMA AIR MANAGER at any time (point-to-point connection). Only when the existing link is
disconnected can another communications peer create a new link. This means that
redundant systems with several communications peers that can simultaneously
communicate with SIGMA AIR MANAGER cannot be set up.

The link is permanently implemented in SIGMA AIR MANAGER and cannot be changed.

In communication terms, SIGMA AIR MANAGER only represents a passive subscriber that
accepts and carries out communications commands (FETCH/WRITE or SEND/RECEIVE)
from active peers.

SIGMA AIR MANAGER supports a user data record of maximum 240 data bytes (120 data
words) per data message. Generally, this limitation has to be kept to by the communications
peer, for example, during the execution of a FETCH command.

Commensurate with the general SEND/RECEIVE specification, only one predetermined data
area from an S5 data block can be written and read per SEND/RECEIVE connection. With
SIGMA AIR MANAGER only the S5 data block DB34 may be written (see chapter 5.1 and
5.2) and only the S5 data block DB31 (see chapter 5.1) as well as data blocks DB120-DB135
(SIGMA CONTROL Compr.1 — Compr.16, see chapter 5.3) may be read.

With FETCH/WRITE, it is possible to read all S5 data blocks containing process data (see
chapter 5.3). However, only the S5 data block DB34 may be written in this case (see chapter
5.1).

SIGMA AIR MANAGER does not support the ISO transport protocol.
The maximum transfer rate with SEND/RECEIVE communication is 10 Mbit/s.
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4 Initial Start-Up

4.1 SIGMA AIR MANAGER

First, the SEND/RECEIVE option package has to be registered at KAESER. To do this, the
“Release Code Request” form supplied is to be filled out fully by the customer and faxed or
e-mailed to KAESER. KAESER then registers SEND/RECEIVE and grants a single license
for the customer’s SIGMA AIR MANAGER according to the license conditions attached, in
that KAESER provides the customer with the registration code (release code). The
registration code is needed to unlock the SEND/RECEIVE software on SIGMA AIR
MANAGER. System requirements must be borne in mind (see 2). The registration code is to
be entered in SIGMA AIR MANAGER once only. The appropriate menu option is accessed
from the main menu.

[/main menu] > [settings] » [system] > [communication] > [SEND/RECEIVE].

If the registration code has been entered correctly, the FETCH/WRITE or SEND/RECEIVE
specification can be activated in the same menu option. If needed, SEND/RECEIVE can be
deactivated here at any time. The specification SEND/RECEIVE has the options ,SAM*“ and
SAM+SC*. By choosing the option ,SAM* only the process image of the SIGMA AIR
MANAGER will be transferred. By choosing the option ,SAM+SC* additionally the process
images of the SIGMA CONTROL compressors linked to SIGMA AIR MANAGER will be
transferred.

As communication via SEND/RECEIVE is based on Ethernet and TCP/IP, SIGMA AIR
MANAGER and the communications peer have to be networked via Ethernet and exist in the
same TCP/IP network. In addition, SIGMA AIR MANAGER’s IP address, subnet mask and, if
required, the IP address of a router can be set up. The appropriate menu option is accessed
from the main menu:

[main menuj > [settings] » [system] > [interfaces] > [Ethernet].

SIGMA AIR MANAGER has to be restarted to activate the SEND/RECEIVE and the TCP/IP
settings that were made. Switch the power supply to SIGMA AIR MANAGER off and then on
again (using the cutout in the control cabinet or the user's power switch).

The remote control functions via SEND/RECEIVE are only effective if SIGMA AIR
MANAGER is running in remote control mode. If remote control mode is ended, the current
operating mode (OFF/ON, Manual/Automatic, Clock OFF/ON and compressor selection) is
retained and the local settings are effective again.

Remote control mode is switched on or off with the REMOTE key and indicated by the LED
(see SIGMA AIR MANAGER service manual).

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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4.2 The SIMATIC S5 PLC as a Communication Peer

4.2.1 Preparatory work

Communication module CP1430TCP is purpose-built for the link-up between SIGMA AIR
MANAGER and the SIMATIC S5 station. It makes possible the networking of the S5-115U/H,
S5-135U or S5-155U/H systems with other communications peers (e.g. SIGMA AIR
MANAGER) via Ethernet and, in addition, supports the RFC 1006 protocol (S5-compatible
communication) with the SEND/RECEIVE and FETCH/WRITE specifications. This is why,
depending on the application in question, the SEND/RECEIVE or FETCH/WRITE
specification has to be activated.

The appropriate SIGMA AIR MANAGER menu option is accessed from the main menu:
[/main menuj > [settings] > [system] > [communication] > [SEND/RECEIVE].

The “STEP5” software package from Siemens must be installed on a PC to allow setting up
and/or programming of the SIMATIC S5 programmable logic controller. The SINEC NCM
COM 1430 TCP set-up software is required to set up and program the CP1430TCP
communications module. A TTY line link is needed to transfer the settings entered in the S5-
CPU and CP1430 TCP.

As this description is only meant to be an explanation of a simplified procedure for initial start-
up of S5-compatible communication between a SIMATIC S5 station and a SIGMA AIR
MANAGER, detailed areas of the software will only be described with regard to their necessity.

Further information on the “STEP5” and SINEC NCM COM 1430 TCP programming software
can be found in the appropriate user manuals.

Additional information on the S5 hardware and software and its accessories can be found in
the Siemens Catalogue ST50.

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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4.2.2 Setting up the S5 station with the SEND/RECEIVE connection
In the main, this involves the following steps:

e Configuration of the CP1430 TCP communications module

e Setting up the active communications link

e Embedding the function module in the STEP5 program

The individual steps are explained below: The images shown refer to an S5 station fitted with
an S5-115U with the CPU944B and the CP1430TCP communications module. Settings that
lie within the judgment of the user are not explained further.

4.2.2.1 Configuration of the CP1430 TCP communications module

The CP1430TCP communications module is the connecting link providing communication
between the S5-CPU and the industrial Ethernet-linked SIGMA AIR MANAGER. It
exchanges messages with the S5-CPU through a common interface (dual port RAM).
Unambiguous access to/from the communication peers in the Ethernet network is dependent
on the IP-address. The SINEC NCM COM 1430 TCP program assists in the stipulation of the
area of the interface needed in the dual port RAM and in the IP address set-up. First of all,
the STEP5 program has to be started. Next, load the STEPS project software to allow the
project directory to be determined. Afterwards, click on Change> further... F9 and the user
interface for Other SIMATIC S5 programs appears. The SINEC NCM COM 1430 TCP
program is started by marking SINEC NCM COMs and then clicking <Start>.

=101.x]

Other SIMATIC 85 Programs

Program: SINEC MCM COM=s . ... .........c..--. U581
—»C:~ETEP5~55_COMNCPi43BIP

rEro irams : rDrsdirectory ﬁ

T
-
|
—

|—||—||—||—||T||—||—||—|
"—u'—'=ﬂ"|ﬂl'1'.|ﬁﬁ
[ S S |

l_ — =
sorted: up
Hame Designation Date PG
C:S5PECSHE .CMD SINEC HCM 24.85_95% 758 < Select F3 >
< Dirs Fo6 >
£ Start > < Cancel ESC > < Enahle drive FS > < Help Shift+F8 >
Image 1: “SINEC NCM COM1430” program start
© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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The basic settings are accessed with File > Select. Here, the input fields CP1430IP as CP
type and OFFLINE FD as Status are marked for offline setup and then selected with F8
SELECT. In addition, the filename of the CP1430 setup file (must start with the character T)
and the working directory, which corresponds with the project directory determined in STEP5,
is defined. The remaining settings can be ignored here. The settings are entered with F7 OK
and the main menu appears again.

SINEC MCH

Basic Settings

CP type = CIFEEIN Status = PINLTHNG
Databaze file HERCIEFET CP1438.CP1
Documentation : Footer E
Printer output (
Printer file 3 E HENOMAME ) N )
Footer file 5 HENONAMEF1 i, 1|

QK 8§ SELECT

Image 2: Basic settings for CP1430TCP

The dialog for the identification setup of CP1430TCP in the Ethernet is accessed with menu
options Edit » CP Init. A net-wide unambiguous address has to be entered as a physical
address (MAC address). If the CP1430TCP is operated in a local Ethernet then the default
value can be retained. A number that can be divided by four is entered as the Base interface
number. In principle, this represents the address with which an unambiguous memory area in
the Dual Port Ram of the CP1430 TCP is determined. The remaining settings can be ignored
here. The settings are entered with F7 OK and the main menu appears again.

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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FISTEP 5
COM1438TCP-IF U2 _@7
CP Basic Initialization Source: C:T_CP1438.CP1 <OFFLINE>
MAC address <HEX> HE - B AP6 A1 BAA1
SIMATIC details
Base SSHR HEE |
Interface
communication <P/ /B)» : P [ | B B
SSHNR offset 3 a 1 2 3
Informative parameters:
Card type 3 Datahase size 3 64 Kb
Module ID : CPi4381IP
Firmuware version 3 Date created A 11 2 A
Plant deszignation 3 P1438<{—>SAM

9 9 g g ____§ i |
1 2 3 4 5 [ ?

QK 8§ SELECT

Image 3: Initialization of the CP1430TCP

The TCP/IP initialization dialog is then accessed with Edit > TCP/IP Init. The settings for
the local TCP/IP specifications of the CP1430TCP are entered here. Any character sequence
(max. 25 characters) can be entered as a host name, although this is not absolutely
necessary. The IP-address for the CP1430TCP must exist in the same subnet as the link
partner (SIGMA AIR MANAGER). The subnet setting in SIGMA AIR MANAGER under

[/main menu] > [settings] > [system] > [interfaces] > [Ethernet],

must also be entered here. If the Ethernet link to SIGMA AIR MANAGER is via a gateway,
then the address of the default gateway has to be entered as well. The settings are entered
with F7 OK and the main menu appears again.

[F]STEP 5
COM143aTCPAIP U2 a7 SN

TCP/IP initialization Source: C:T_CP1438.CP1 (OFFLINE)

Host Hame <(ASCII2 HECF1438

IP Address <dec.? A

IP Address (hex.2? : A?FECS1E

Default Gateway ¢ASCII)> :

IP Address (dec.) '167.254.200.030

Hetmask <dec.> HC LG . 255 . 986 . BBA

F_F_F_F_F_F_F-IE_
1 2 3 4 5 6 7 OK 8

Image 4: TCP/IP initialization of the CP1430TCP

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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4.2.2.2 Setting up the active communications connection

As only one S5 compatible communications connection from SIGMA AIR MANAGER can
exist at one time, only one bi-directional connection is required with the SEND/RECEIVE
specification. This is accessed from the main menu with Edit > Connections > Transport
Conn. (RFC1006) in the dialog Transport Connection (TCP/RFC1006). New transport
connection jobs are entered with F3 INPUT. A selection box can be displayed with F8
SELECT on all input fields for which a selection list is available. The selection is entered with
the ENTER key.

The SSNR offset parameter, in conjunction with the basic interface number (see chapter
5.2.2.1), determines the final interface number for the communications channel. The default
value 0 should be kept.

The ANR parameter represents a job number. Together with the CP1430TCP interface
number it identifies a communications job if an S5 standard function module (function block)
— provided with the appropriate formal SSNR und A-NR parameters — is called up in the
STEP5 user program.

The Job type determines whether it is a SEND, RECEIVE or FETCH job. In this case, select
SEND.

The Active/passive (A/P) parameter indicates whether or not the transport connection has
initiated the connection set-up. This is to be set to A.

With regard to the SEND/RECEIVE specification, the Read/write (Y/N) parameter determines
whether or not the default parameter comes from the communications peer. This is to be set
to N.

Enter 2 (1 of 2) for the Number of jobs per TSAP parameter. This means that a TSAP pair is
assigned two jobs (TSAP = Transport Service Access Point), i.e., the TSAP of the local and
the TSAP of the remote communications peer. The second job will be the RECEIVE job,
which is the next to be setup.

The S-KAESER ID must be entered as the TSAP (ASC) of the local communications peer
(CP1430 TCP) in the column Loc. Parameters:. The entries for TSAP (hex) and TSAP length
are added automatically.

The settings for the remote communications peer (SIGMA AIR MANAGER) are entered in
the column Rem. Parameters:. The |IP address entered in the SIGMA AIR MANAGER under

[/main menuj > [settings] > [system] > [interfaces] > [Ethernet]

is to be entered as the IP address. If an identifier with its IP address is assigned to the
communications peer in the dialog Hostnames with Edit > Hostnames, this can be entered
under Hostname. The ID S-KAESER must be entered as the TSAP (ASC). The entries for
TSAP (hex) and TSAP length are added automatically.

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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[FsTEP 5

COM1438TCE-IF V2 _ a7Ed%])
Transport Connection <TCP-RFC1886 3> Source: C:T_CP1438.CP1 <OFFLIHE>»

SSHR offset | ANR B
Joh type HECEND | Activespassive (A/P> = 7]
Read-write {Y~/N>» HE| TCP Keep—Alive (Y- N> = {

Humber of jobs per TSAP 1 of 2

Transport addresses:

Loc. parameters: Rem. parameters:
Hostname H
IP address =
TISAaP <ASC> = PRSI TEAP <ASCY> =
TSAP (HEHX> : RERC  iEVE R LT TSAP <HEX> : ERFOEEJES
TSAP length: } TSAP length: }

w9 8 4§ g i |
1

0
+1 2 -1 3 INPUT 4 DELETE &5 6 7 0K 8 SELECT

Image 5: Setting up a SEND job

Save the planned job with F7 OK. As the value 2 was selected as the setting for the Number
of jobs per TSAP, setup of the second job (RECEIVE job) is expected straightaway. The job
number ANR is automatically increased by one. Both this preset value and that of the SSNR
offset parameter are adopted. RECEIVE is now selected for the Job type parameter. Save
the planned job with F7 OK.

Confirm the overwrite job query with F1 YES.

[F]STEP 5

COM143ATCP-IF V2 a7 EdEINe
Tranzport Connection (TCP~-RFC1886 > Source: C:T_CP1438.CP1 <(OFFLINE>

S8NR offset o | ANR : BHE
Jobh type : Activespassive (A-P> = A
Read write C(Y.-/N> : N TCP Keep—Alive (Y¥Y-sN> = ¥
Mumbher of jobhs per TSAP : 2 of 2

Transport addresses:

Loc. parameters: Rem. parameters:
Hostname : SAN
IPF address : 16%7_254_208.014
TSAPF (ASC> : S—KAESER TSAP <(ASC> : S—-KAESER
TSAF (HEX> : 53 2D 4B 41 4% 53 45 52 TSAP (HEX> = 53 2D 4B 41 45 53 45 52
TSAP length: 8 TSAP length:- 8

F_F_F_F_F_F_F_F-]]E_
i +1 2 -1 3 INPUT 4 DELETE &5 6 7 0K 8 SELECT

Image 6: Setting up a RECEIVE job

Now, the CP1430TCP is set to the STOP status with CP-Functions > Stop so that the file can
be transferred to the CP1430TCP with Transfer » FD—CP. All job data blocks are loaded
into the CP1430TCP with F2 TOTAL. Afterwards, set the CP1430TCP to the RUN status
again with CP-Functions > Start.

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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Finally, exit the SINEC NCM COM 1430 TCP program with File > Exit and return to the
STEPS program with <Cancel ESC>.

4.2.2.3 Embedding the function modules in the STEP5 user program

After configuring the CP1430TCP, the S5 standard function modules (function blocks) have
to be embedded in the STEPS5 user program. The function blocks, integrated in the operating
system of the S5 CPU and listed below, control, among other things, the exchange of data
between the CP1430TCP and the S5 CPU.

FB249 - SYNCHRONOUS
FB244 - SEND
FB245 - RECEIVE

The SYNCHRONOUS FB, called up from the start-up organization block (OB21 or OB22) of
the STEPS5 application program, initiates definition of the interface on the communication
module for communication between the CP1430TCP and the S5-CPU when the complete S5
PLC system has run up. This synchronization is necessary to make sure that all other
function blocks can function correctly.

The FB SEND is needed in the S5 application program primarily for transfer of data from the
S5 CPU to the CP1430TCP (SEND ALL with the job number 0).

In order to be able to actually carry out an active SEND connection job planned in the
CP1430TCP, the SEND FB has to be called up additionally once per job with the appropriate
parameters (SEND DIRECT with the job number n).

As the communications peer initially sends the data to the CP1430TCP, the RECEIVE FB
(RECEIVE ALL with the job number 0) has to be called up for forwarding to the S5 CPU.
The actual initiation, however, first takes place through a further call-up of the RECEIVE FB
(RECEIVE DIRECT with the job number n). This has to be provided with the appropriate
parameters corresponding with the RECEIVE connection job that was set up in the CP1430
TCP.

A detailed description of the S5 standard function modules and their various call-up variants
is to be found in the equipment manual for the automation equipment used, e.g. “SIMATIC
S5 Programmable Logic Controller S5-115U”. The STEP5 example program in Annex A can
be used as a template for the compilation of the STEP5 user program.

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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4.2.3 Setting up the S5 station with the FETCH/WRITE connection
In the main, this involves the following steps:

e Configuration of the CP1430 TCP communications module
e Setting up the active communications link
e Embedding the function module in the STEP5 program

The individual setting-up steps are explained below: The images shown for illustration refer
to an S5 station fitted with an S5-115U with the CPU944B and the CP1430TCP
communications module. Settings that lie within the judgment of the user are not explained
further.

4.2.3.1 Configuration of the CP1430 TCP communications module

The procedure is as already described in chapter 4.2.2.1.

4.2.3.2 Setting up the active communications link

As only one S5 compatible communications connection from SIGMA AIR MANAGER can
exist at one time, only one bi-directional connection is required with the SEND/RECEIVE
specification. This is accessed from the main menu with Edit » Connections > Transport
Conn. (RFC1006) in the dialog Transport Connection (TCP/RFC1006). New transport
connection jobs are entered with F3 INPUT. A selection box can be displayed with F8
SELECT on all input fields for which a selection list is available. The selection is entered with
the ENTER key.

The SSNR offset parameter, in conjunction with the basic interface number (see chapter
5.2.2.1), determines the final interface number for the communications channel. The default
value 0 should be kept.

The ANR parameter represents a job number. Together with the CP1430TCP interface
number it identifies a communications job if an S5 standard function module (function block)
— provided with the appropriate formal SSNR und A-NR parameters — is called up in the
STEPS5 user program.

The Job type determines whether it is a SEND, RECEIVE or FETCH job. In this case, select
SEND.

The Active/passive (A/P) parameter indicates whether or not the transport connection has
initiated the connection set-up. This is to be set to A.

With the SEND/RECEIVE specification the Read/write (Y/N) parameter determines whether
or not the default parameter comes from the communications peer. This is to be setto Y.

Enter 1 (1 of 1) for the Number of jobs per TSAP parameter. This means that a TSAP pair
(TSAP = Transport Service Access Point), i.e., the TSAP of the local and the TSAP of the
remote communications peer, is assigned one job.

The ID W-KAESER must be entered as the TSAP (ASC) of the local communications peer
(CP1430 TCP) in the Loc. Parameters column. The entries for TSAP (hex) and TSAP length
are added automatically.

The settings for the remote communications peer (SIGMA AIR MANAGER) are entered in
the column Rem. Parameters:. The IP address entered in the SIGMA AIR MANAGER under

© KAESER KOMPRESSOREN GmbH 18.11.2005 www.kaeser.com
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[/main menuj > [settings] > [system] > [interfaces] > [Ethernet]

is to be entered as the IP address. If an identifier with its IP address is assigned to the
communications peer in the dialog Hostnames with Edit > Hostnames, this can be entered
under Hostname. The ID W-KAESER must be entered as the TSAP (ASC). The entries for
TSAP (hex) and TSAP length are added automatically.

[F]STEP 5

COM143ATCP-IF V2 a7 EdEINe
Tranzport Connection (TCP~-RFC1886 > Source: C:T_CP1438.CP1 <(OFFLINE>

S8NR offset | ANR :
Jobh type HECEND | Activerspassive (A-PY> = 7
ReadAurite (Y./N> I | TCP Keep—Alive (Y-N> =
Mumbher of jobhs per TSAP 1 of 1
Transport addresses:
Loc. parameters: Rem. parameters:

Hostname IS A M

IP address = (LR ILE I SN
TSAP <ASCY> : IETIEIE TSAP <ASCY = [
PRI ? 2D 4B 41 45 53 45 52 TSAP <HEX> : ¥aFIOEE1EN
TSAP length: i TSAP length: i

F_F_F_F_F_F_F_F-]]E_
i +1 2 -1 3 INPUT 4 DELETE &5 6 7 0K 8 SELECT

Image 7: Setting up a WRITE job

Save the planned job with F7 OK. Confirm the overwrite job query with F1 YES.
Now create a new job with F3 INPUT.
Accept the SSNR offset parameter with its default value.

Set the ANR parameter with the higher job number proposed. As previously mentioned, this
job number serves ultimately, together with the interface number of the CP1430 TCP, the
unambiguous allocation of the communication job. In the STEP5 application program the
SSNR and A-NR formal parameters have to be set with these values when the S5 standard
function module (function block) is called up.

Enter the receive job type FETCH in the Job type field.

The Active/passive (A/P) parameter indicates whether or not the transport connection has
initiated the connection set-up. This is to be set to A.

Set the Read/write (Y/N) parameter to Y.
Enter 1 (1 of 1) for the Number of jobs per TSAP parameter.

The ID F-KAESER must be entered as the TSAP (ASC) of the local communications peer
(CP1430 TCP) in the Loc. Parameters column. The entries for TSAP (hex) and TSAP length
are added automatically.

The settings for the remote communications peer (SIGMA AIR MANAGER) are entered in
the column Rem. Parameters:. Under IP address the address entered in the SIGMA AIR
MANAGER menu under

[/main menuj > [settings] > [system] > [interfaces] > [Ethernet]
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is to be entered. If an identifier with its IP address is assigned to the communications peer in
the dialog Hostnames with Edit > Hostnames, this can be entered under Hostname. The ID F-
KAESER must be entered as the TSAP (ASC). The entries for TSAP (hex) and TSAP length
are added automatically.

[FsTEP 5

COM1438TCP-IF V2 _a7EdEI N
Transport Connection <TCP-RFC1886 3> Source: C:T_CP1438.CP1 <OFFLIHE>»

SENMR offset | AMR : BE
Joh type H Activerspassive (A/PY = 7]
Read-write {Y~/N>» HI | TCP Keep—Alive (Y- N> = {
Mumber of jobs per TSAP : 1 of 1

Transport addresses:
Loc. parameters: Rem. parameters:

Hostname 3

IP address =
TSAP {ASC> = DRI TSAP <ASC> :
TSAP (HEX> = IR VIETEETEENE S TSAP (HEX>» :=
TSAP length: } TSAP length: }

W 9 8 4§ __§ ____§ 1 |
i +1 2 -1 3 IWPUT 4 DELETE 5 6 7 0K 8 SELECT

Image 8: Setting up a FETCH job

Now, the CP1430TCP is set to the STOP status with CP-Functions » Stop so that the file can
be transferred to the CP1430TCP with Transfer » FD—CP. All job data blocks are loaded
into the CP1430TCP with F2 TOTAL. Afterwards, set the CP1430TCP to the RUN status
again with CP-Functions > Start.

Finally, exit the SINEC NCM COM 1430 TCP program with File » Exit and return to the
STEPS program with <Cancel ESC>.
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4.2.3.3 Embedding the function modules in the STEP5 user program

After configuring the CP1430TCP, the S5 standard function modules (function blocks) have
to be embedded in the STEP5 user program. The function blocks, integrated in the operating
system of the S5 CPU and listed below, control, among other things, the exchange of data
between the CP1430TCP and the S5 CPU.

FB249 - SYNCHRONOUS
FB244 - SEND

FB245 - RECEIVE

FB246 - FETCH

The SYNCHRONOUS FB called up from the start-up organization block (OB21 or OB22) of
the STEPS5 application program initiates definition of the interface on the communication
module for communication between the CP1430TCP and the S5-CPU when the complete S5
PLC system has run up. This synchronization is necessary to make sure that all other
function blocks can function correctly.

The FB SEND is needed in the S5 application program primarily for transfer of data from the
S5 CPU to the CP1430TCP (SEND ALL with the job number 0).

In order to able to actually carry out an active WRITE connection job planned in the
CP1430TCP, the SEND FB has to be called up additionally once per job with the appropriate
parameters (SEND DIRECT with the job number n).

As the communications peer initially sends the data to the CP1430TCP, the RECEIVE FB
(RECEIVE ALL with the job number 0) has to be called up for forwarding to the S5 CPU.
The actual initiation, however, first takes place through a further call-up of the FETCH FB
(FETCH DIRECT with the job number n). This has to be provided with the appropriate
parameters corresponding with the FETCH connection job that was set up in the CP1430
TCP.

A detailed description of the S5 standard function modules and their various call-up variants
is to be found in the equipment manual for the automation equipment used, e.g. “SIMATIC
S5 Programmable Logic Controller S5-115U”. The STEP5 example program in Annex B can
be used as a template for the compilation of the STEP5 application program.
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4.3 The SIMATIC S7 PLC as a Communications Peer

4.3.1 Preparatory work

Communication modules CP343-1 and CP443-1 are purpose-built for the connection
between SIGMA AIR MANAGER and the S7 300 and S7 400 SIMATIC S7 stations. Both
modules support S5-compatible communication with SEND/RECEIVE specification.

The appropriate SIGMA AIR MANAGER menu option is accessed from the main menu:
[/main menu]j > [settings] > [system] > [communication] > [SEND/RECEIVE].

The software package “STEP7” from Siemens must be installed on a PC to allow setting up
and/or programming of the SIMATIC S7 station. Furthermore, the project planning PC and
the corresponding S7 CPU must be connected via an MPI (Multi Point Interface) cable.

Additional information on the S7 hardware and software needed and its accessories can be
found in the Siemens ST70 Catalogue.

4.3.2 Setting up the S7 station with the SEND/RECEIVE connection
In the main, this involves the following steps:
e Entering the project components
e Arrangement and parameterization of the S7 hardware in the configuration table
e Configuration of the link peer
e Setting up the active communications link
e Embedding the function module in the STEP7 program

The individual steps are explained below: The images refer to an S7 300 station with a
CPU315-2DP and a CP343-1 communications module. Settings that lie within the judgment
of the user are not explained further.

4.3.2.1 Entering the project components

In order to set up the S7 station, the STEP7 setup and programming user interface has to be
started with Start > Simatic > STEP7 > SIMATIC Manager. Before configuration can be
carried out, an S7 project must be either started or a new one made up in SIMATIC
Manager. A SIMATIC 300 or 400 station with an S7 program, Other station and finally
Industrial Ethernet as the subnet are inserted into the opened project. Select the opened
project by clicking on it before each insertion.
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SIMATIC 300 Station:

For the own S7 program (Rack, PS, CPU, CP343-1, ...): Insert » Station » SIMATIC 400
station and Insert > Program » S7 program

For the link peer (SIGMA AIR MANAGER): Insert » Station » Other station

For an industrial Ethernet network between the SIMATIC 300 station and the link peer: Insert
» Subnet > Industrial Ethernet.

SIMATIC 400 Station:

For own S7 program (Rack, PS, CPU, CP443-1, ...): Insert » Station » SIMATIC 400 station
and Insert > Program » S7 program

For the link peer (SIGMA AIR MANAGER): Insert » Station > Other station

For an industrial Ethernet network between the SIMATIC 400 station and the link peer: Insert
» Subnet > Industrial Ethernet.

QSIMATIE Manager - [SMDRCY -- C: Program Files', SIEMENS!, SIMATIC.NCM 57proj'Snd — |EI|£|
% Eile Edit Insert PLC Wiew Options ‘Window Help - |ﬁ'|£|
O] 22l =l il (o = [ < No Fiter > =1%| s ==m| x|

E--@ SMDRCY Object name | Syrmbolic narme | Type | Sizel Author
= CPU3IS-20F CPUZ15-2DF SIMATIC 300 Station
'%"" LRU 3152 DR B Dther station(S4M) Dther station 1208
- =G 57 Frogiam T =T indstrial E themel 36
(B Sources
“-{gH Blocks
- CP 3431
1] | i
Press F1 ko get Help, [ [ v

Image 9: Overall view of the SIMATIC S7 station with the project components
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4.3.2.2 Arrangement and parameterization of the S7 hardware in the configuration
table

The S7 hardware components used for the hardware configuration are now arranged on the
rack according to their card slots and their properties are determined. To do this, the
hardware configuration (HW config) is started by selecting the SIMATIC 300 station and
double-clicking Hardware (or Edit > Open object).

SIMATIC 300 Station:

Insert a RACK 300, a PS-300, a CPU-300 from SIMATIC 300 and the CP Industrial Ethernet
CP343-1 from CP-300 with the corresponding order numbers in each case with Insert >
Insert Object.

SIMATIC 400 Station:

Insert a RACK 400, a PS-400, a CPU-400 from SIMATIC 400 and the CP Industrial Ethernet
CP443-1 from CP-400 with the corresponding order numbers in each case with Insert >
Insert Object.

The procedure for the configuration of S7 300- or S7 400 modules is described in detail in
the “User’'s Manual for STEP7”.

E—,EHW Config - [CPU315-2DP {Configuration) -- SNDRCY] - |EI|1|
E“] Station Edit Insert PLC Yew Options ‘Window Help _|ﬁ'|i|
D[22 % & == o€ B= 38 s

==(0] UR d

1 PS 2307 24 J

2 CPU 315-2 DP

A DE

: -

@

B

7

g

k]

10

11

=0 w
todule Order number Firmweare | MPl address | | address | O addiess Comment

PS 307 24 BES7 307-1BAD0-0AAD -

CPU 315-2 DP BESY 315-2AF03-0AB0 V1.2 2

OF T —

CP 3431 EGKF 343-1EX11-0=ED 2.0 3 256,271 |256..271

Il

Press F1 to get Help, l_ L I
mage 10: Hardware configuration of the SIMATIC S7 station
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Now, the CP343-1 or CP443-1 communications module has to be parametrized. To do this
start the parameterizing user interface by double clicking on CP x43-1 in the dialog window
for the hardware configuration (HW Config) or by marking the CP and selecting the Edit >
Object Properties menu option. Select Properties in the General tab to access the Ethernet
user interface with the Parameters tab in which the communications processor is given its |P
address and the appropriate subnet mask. The IP-address for the CP must exist in the same
subnet as the link peer (SIGMA AIR MANAGER). The subnet setting in SIGMA AIR
MANAGER under

[/main menuj > [settings] > [system] > [interfaces] > [Ethernet],

must also be entered here. If the Ethernet link to SIGMA AIR MANAGER is via a router, then
the address of the router has to be entered as well. Also, the CP has to be linked to the
industrial Ethernet subnet in the Subnet field. This is accomplished by marking the
appropriate entry. On newly created Ethernet subnets this is normally designated with
Ethernet(n).

The creation of a MAC address is not necessary for SEND/RECEIVE communication.

i3 Hw Config - [CPU315-2DP -1l x|
E“] Station  Edit  Insert PLC  Wiew Opkions  Window  Help - |5’|i|
P PR N Coeroperties coséa ﬂ
General |.t’-‘«ddresses| Dptionsl Diagnosticsl Addressingl . -
1 PS 30 St D Properties - Ethernet interface CP 343-1 (RO,/54) il J
2 CPU
Xz oF General  Parameters |
3
4 [~ Set MaC addiess / uze [S0 protocal
3
E Order Mo/ firware MAC address: I
7 | Mame: L
g ¥ P protocol s being used
3 — Interf
s | [ IP address: [169.254.200.16 ptenay
L — Tupe: * Do not uge rauter
11 Subnet maszk: |255.255.D.D
Address: " Use router
MNetworked: Address: |159.254.2DD.1E d
1 | Subnet:
— Comment: =
— - it fetworked - New
ﬂ ZI [0 UR EthemetSND_REC)
Froperties. .. |
Module
Delete |
DK
4| Ok, I Cancel | Help |
[
Press F1 ko get Help. v
Image 11: Configuration of the S7 communications module
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The parameterization of the Ethernet interface is entered with the OK button. The input and
output start addresses can be noted in the Address tab. This is normally predefined by the
system. This start address is needed later for provision of the formal parameters LADDR
when calling up the S7 system function block in STEP7 for send/receive of data in the
STEP7 source code.

SEND/RECEIVE with SIGMA AIR MANAGER

[ 1w config - [CPU315-2DP (Configuration) -- SNDRCY] =101 x|
[l station Edit Insert PLC Wiew Options Window Help ===l
D|23~2 (8| S| B2 ol B=] 32 w2
= (0] U Properties - CP 343-1 - (R0/54) x| ﬂ
1 P 207 24 General Addresses | Dptionsl Diagnosticsl Addressing J
2 CPU 315-2 DF
XE OF — Input
Start: Length: 1B ¥ System selection
B
7
g
] r— Dutputs
10
11
Start: 256 Length: 16 IV System selection
b
4| »
o v
Sat | Moduls
PS 307 24 -
CPU 315-2 DP
CP 3431
5 Cancel Help | LI
Press F1 to get Help. | A

Image 12: Input and Start addresses of the S7 communications module
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A data length of more than 240 bytes for processing by the communications module can be
chosen in the Options tab. Select the setting TP/ITP at 10Mbps full duplex as the
Transmission medium/duplex.

All the other default settings can be accepted. As SIGMA AIR MANAGER supports a user
data record of maximum 240 data bytes (120 data words) per data message, this setting is of
no consequence.

@L-,I:HW Config - [CPU315-2DP {Configuration) -- SNDRCY] — |EI|5|
[l station Edit Insert PLC Wiew Options Window Help =] x|
D52 (50| S| || dolda| =] %8| a2
= (0] UR Properties - CP 343-1 - (RO/54) x| ;I
! PS 307 24 General | Addiesses  Options | Diagnostics | Addressing J
2 CPU 315-2 DI
= De
7
5
E — Replace Module without PG
; ¥ Save configuration data on the CPU
3 - .
10 r— Individual Metwark, Settings
11 Tranzsmizsion medium/duples:
—Send Keepalives for Connections -
1] Interval [geconds] [value range 0-55535) |3U L4 I
ﬂ:l [0 UR — ultiplex OF Connections
Slot | Fodule [ Beserve CPU connection resource
PS5 307 24 -
CPU 315-2 DF
CP 3431
5 Canhcel | Help | LI
Press F1 ta get Help, | v

Image 13: Optional settings for the S7 communications module

To close the overall parameterization of the CP343-1 or CP434-1, close the Properties -
CP343-1 or Properties - CP434-1 dialog by clicking OK. Having returned to the hardware
configuration (HW Config) window, the hardware configuration for the complete S7 station
has to be closed with Station > Save and Compile. Finally, the complete hardware
configuration has to be transferred into the target module CPU3xx or CPU 4xx with PLC »
Download.
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Assuming that the STEP7 project in SIMATIC Manager is open, the properties of the
communication peer’s Other station now have to be configured by double clicking it (or
marking it and selecting with the menu option Edit > Object Properties). The interface type is
selected in the Interfaces tab by clicking New, selecting Industrial Ethernet and accepting
with OK. In the popup Ethernet interface properties dialog the IP address and the
communication peer’s (SIGMA AIR MANAGER) subnet mask are entered. Basically, these
settings are the same as those in the SIGMA AIR MANAGER menu

[/main menu] > [settings] > [system] > [interfaces] > [Ethernet]

that are already entered. The communications peer has to be linked to the industrial Ethernet
subnet in the Subnet field. This is accomplished by marking the appropriate entry. Click OK
twice to return to the SIMATIC MANAGER’s main menu.

SEND/RECEIVE with SIGMA AIR MANAGER

4.3.2.3 Configuring the communication peer’s station

ESIMATIE Manager - [SNDRCY -- C:%Prog - |EI|5|
% File Edit Insert PLC \View Options ‘Window Help - |E|5|
Ol 23z &= dl = s [< Mo Fier> =% 2@ &3m 2

E--% SMORCY Object name I Symbalic name I Type I Sizel Author
=HE CRUZS-20P CPU315-2DP SIMATIC 200 Station
& CPU315-20F B Other station[Sah] Dther station 1208
. =@ SrRedn R EthemelSND_REC] Industial Ethernet 2264
N x
ﬂ]—‘. CP 3431 General  Interfaces |
MHame | Type | Address | Subnet
Ethemnet porti1]  Industrial Ethernat 169.254.200.14 Ethermet|SHD_REC]
Hew Froperties... [elete |
0K | Cancel Help |
11 | _’I
Fress F1 to get Help. |1208 Bytes [ v

Image 14: Configuring the communication peer’s station
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4.3.2.4 Setting up the active communications link

The CP343-1 or CP443-1 communications module is the connecting link providing
communication between the S7-CPU and the industrial Ethernet-linked SIGMA AIR
MANAGER. This means that for the connection of the relevant interface to the
communications peer, suitable connection settings corresponding to the unchangeable
connection settings in SIGMA AIR MANAGER have to be entered in the S7 station.

In the STEP7 project the CPU is selected in the opened S7 300- or S7 400 station for this
purpose and the program NetPro is started by double clicking Connections. A block diagram
of all stations and all planned sub-systems is displayed.

E‘}__%Netprn - [SMDRLCY (Metwork) -- C:Program Files',...\s7projSndrcy ] - |E||5|
%Eﬁetwork Edit Insert PLC Wiew Options Window Help 18] x|
(@ %] 8| || )il 6| o] Bl el

EthernetSND_REC) [

Industrial Ethernet

M Cther station(SAM)

CPU315-20P J

=
. | 3

To display the connection table, please select a module capable
of a connection [CPU, FM module, OPC server or application).

Ready % 598 Y 259 |Insert |Chg 4

Image 15: Diagram of all networked communication peers
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Mark the S7-CPU — a list of connections appears in the lower window — and by selecting
Edit> New connection, the Insert New Connection dialog is accessed.

The communications peer to be selected is “Other station with connection type ISO-on-TCP
link. Confirm these settings with OK.

PENetPro - [SNDRCY {Network) -y
) i =
T ————— Insert New Connection x|
- . r— Connection Partter
=|® (% S| =l & _
| E@ In the current project
. =-Bp sNDRCY
BB Dither station{S4M)
- [Unzpecified)
- Al broadcast stations
: e Al multicast stations
@ In unknown project
CPU315-2C
. %
Project: ISNDHC\J -
Station: |Elther station(Sak)
< Ff ol I
Local 1D Partrer IO (Partner
— Connection
Tope:
| Display properties before inserting

=10]x]
=13

Apply

| Cancel | Help

4]

-
3
it Local interface |Partner inte = I

| o

Ready

Image 16: Creating a new communication connection

© KAESER KOMPRESSOREN GmbH

18.11.2005

0 From 0 selected [Insert [Cha 2

www.kaeser.com

Page 25/ 46



SEND/RECEIVE with SIGMA AIR MANAGER KOMPRESSOREN

The dialog for the ISO-on-TCP connection properties now opens. The new connection can
be renamed, for example, SNDRCV«SAM, in the General tab. The connection must be
created actively via the S7 station.

The local ID, e.g. 0001_A050 can be selected in the drop-down menu. The left part 00010f the
ID number represents the connection job number that is needed later for the entering the ID
formal parameter when the S7 system function module in STEP7 source code is called up.

BENetPro - [SNDRCY (Network)

. A - = - Inlll
B yopyork Edic Insert FLC pfinsert New Connecti X == x|

~ . r— Connection Partner
=" |9 S| =|e &

E{E] It the curent project

-89 SHDRCY [
L0 coerties - 150-0n TP comnection x
- [Ur

- Al General | Addreszes | Dp[ionsl Oweryview I Statuz |nfarmation |
| -l
% 11 unkhowr r~ Local Endpaint r— Block FParameters
CPU315-2C
i 1D [Hex): IDDD‘I A050 Yl 1—ip
Name:  [SNDRCv<>5aM| Wi1EH0100—|LADDR
2 2 )
ViaCP:  [CP 3431 - [RO/54)
Froject: ISNE ¥ Active connection establishment
Statiot: IDthe _Iﬂ
< I adule: I 0
Laocal IC Partrer IO (Parter L Ce
r— Connection 1
Tipe [1s0: ol Help |
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J | of
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Image 17: General settings for the new communications connection
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Afterwards, the details for setting up the connection are determined. The SIGMA AIR
MANAGER IP address can be seen in the Partner column in the gray field in the Addresses
tab. The ID S-KAESER is to be entered as the TSAP (ASC) (Transport Service Access Point)
in both the local S7 station and in the partner (SIGMA AIR MANAGER) fields. The entries for
TSAP (hex) and TSAP length are added automatically.

5 NetPro - [SNDRCY {Network) =0l x|

®H8 yevwork Edit Insert PLC v = &) x|
— Connection Parther
=8 % 5| =2 &
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) TSAP (BSC)  |SKAESER [GKAESER
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Image 18: TSAP configuration for the new communication connection
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As only SEND/RECEIVE is possible as the operating mode of a TCP connection with
read/write access on S7 stations, the mode Send/Recv is shown in the gray field in the
Options tab.
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Image 19: SEND/RECEIVE specification for the new communication connection
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The SEND/RECEIVE link is now parameterized sufficiently. All the settings are confirmed
with OK. They appear in the lower window (list of connections).

i‘,}__%NetPro - [SNDRCY {Network}) -- C:' Program Files",...\s7proji,Sndrcy ] - |E||i|
%gﬁetwork Edit Insert PLC Wiew Opftions Window Help -|ﬁ'|5|
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2 2
-
a | »
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000t A0s50 Cther station(SAn) 150-0n-TCP connection (Yes Ethernet(SND_REC) [IE] CP 34341 Ethernet ¢

=
. | 3

Ready 0 from 1 selected [Inserk (Cha 4

Image 20: Diagram of all communication peers and connections

The complete configuration now has to be saved with Network » Save and Compile. In the
next dialog select Compile and check everything. Now start the process by clicking on OK.
Subsequently, mark the S7-CPU in the block diagram again and transfer the complete
network configuration into the CPU3xx or CPU 4xx target module group via the MPI
connection with PLC > Download to current project > Selected Stations.

When the translation process is successfully ended, close the NetPro program with Network
» Exit. The basic menu for SIMATIC Manager appears.
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4.3.2.5 Embedding the function modules in the STEP7 user program

Next, the communication modules FC5 (AG_SEND) and FC6 (AG_RECV) have to be
embedded in the STEP7 program. The FC5 and FC6 functions are found in the
SIMATIC_NET_CP library that is delivered together with the NCM S7 for Industrial Ethernet
software packet. Select File > Open to open the Open project dialog. Here, the
SIMATIC_NET_CP library is located in the Libraries tab. Mark this library and select with

OK.
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&3 FE9 URCY 5TL 5380 Functio
&3 FE12 BSEND 5TL 5284 Functio
3 FE13 BRCY 5TL 5258 Functio
&3 FE14 GET 5TL 4888 Functio
&3 FBIS PUT 5TL 4736 Functio
&3 FB5S IP_COMFIG 5TL 1768 Functio
& Fo DP_SEND 5TL 886 Functio
& F2 DP_RECY 5TL 950 Functio
&3 FC3 DP_DIAG 5TL 1638 Functio
&3 Frd DP_CTAL STL 1292 Functio

A SEND 5
&3 FCE AG_RECY STL 1220 Functio
&3 FC7 AG_LOCK STL B36 Functio
&3 Fr8 AG_UNLOCK 5TL B04 Functio
&3 FC40 FTP_COMMECT 5TL 774 Functio
&3 FC4T FTF_STORE 5TL 1046 Functio
&3 FrCa2 FTP_RETRIEVE 5TL 1118 Functio
&3 Fr43 FTP_DELETE 5TL 770 Functio
QI-F&M FTP QUIT 5TL 370 Functio ™
4 »
Press F1 ko get Help, [ |1610 Bytes [ v

Image 21: List of S7 library modules

SIMATIC 300-Station: Double click on the CP300 folder and then on Blocks to open the
complete library with all the communications modules. Now select the FC5 (AG_SEND) and
FCo6 (AG_RECYV) functions and copy them onto the notepad with Edit » Copy. After changing
to your own STEP7 project with Window » “Own project”” and double clicking on S7-program
(below the open S7-CPU of own S7 station) and then on Blocks, insert the FC5 and FC6
functions into the project with Edit > Paste.
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SIMATIC 400-Station: Double click on the CP400 folder and then on Blocks to open the
complete library with all the communications modules. Now select the FC5 (AG_SEND) and
FCo6 (AG_RECYV) functions and copy them onto the notepad with Edit » Copy. After changing
to your own STEP7 project with Window > “Own project” and double clicking on S7-program
(below the open S7-CPU of own S7 station) and then on Blocks, insert the FC5 and FC6
functions into the project with Edit > Paste.

ESIMATIE Manager - [SNDRCY -- C:Program Files',SIEMENS SIMATIC.NCM' s 7proj'Snd ;|g|5|
£ File Edit Insert PLC Wiew Options Window Help =181 x|
0| 837 & ||| daf [2 2| 2= EElE @ [<Nofies =% s =2m| |

E--% SHDRCY Object name I Symbolic name I Created in language I Size in the wark, memor_l,.ll Type
E‘" CPUZ52DP 59 Spstemdata - EDB
o[ cPUS2DP g0 CYCL_EXC STL 52 Organization B
- B STPegam g gpqgg COMPLETE RESTART  STL B4 Organization B
@ Souress o g AG_SEND sTL 1610 Function
-*li: Cpgﬁm &3 FCE AG_RECY STL 1174 Function
4 FC1m SR:573004-»54M 5TL 382 Function
i3 DBS1 SR:57300->54M ] 29 Data Block
3 DBS4 SR:SAM->57300 DE 296 Data Block
"EP'VAT'I VAT - Yariable Table

4 |

=

Press F1 ko get Help.

Image 22: List of S7 library modules

The purpose of the formal parameters that have to be provided with current parameters
when the FC5 and FC6 communication modules are called up is to be found in the STEP7
reference manual. Alternatively, the online help supplied with STEP7 can be used. After
marking the FC5 or FC 6 function call up line in source code, press F1 to display the related
topic in online help.

The example STEP7 program in Annex C can be used as a template in the same way.

All objects and system data in the target module CPU3xx or CPU4xx are to be transferred
with selection of PLC » Download and “Blocks”.
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5 Data Interface

5.1 Monitoring the Connection

The SEND/RECEIVE connection between SIGMA AIR MANAGER and the communications
peer can be monitored in remote control mode. This is made possible by a handshake
program that is stored in SIGMA AIR MANAGER and activated and used by the
communications peer. The parameters for the handshake program are the activating bit, the
handshake bit and the handshake period that can all be preset via SEND/RECEIVE. The
related S5 addresses (data block, data word) are quoted in the table of all available remote
control functions (see 5.2). The handshake period is 10 to 9990 seconds.

The handshake bit has to be cyclically set by the communications peer when the handshake
is activated (activating bit). SIGMA AIR MANAGER resets the handshake bit and starts the
handshake period at the same time. The handshake bit has to be recognized as set again
before the period expires. Otherwise SIGMA AIR MANAGER reports a SEND/RECEIVE
fault, closes down all SEND/RECEIVE functions and reverts back to LOCAL settings (SAM-
internal settings).

5.2 Remote Control Functions

The requirements for the remote control of SIGMA AIR MANAGER functions are that
SEND/RECEIVE is activated and that remote control mode is activated.

SEND/RECEIVE control functions have a higher priority than corresponding operating
functions on SIGMA AIR MANAGER or input functions (control of digital inputs).

If, for example, the command System ON is sent, then the air system cannot be switched off,
neither by pressing the OFF key on SIGMA AIR MANAGER nor via the activated Remote
OFF/ON input function. A corresponding instruction is displayed on SIGMA AIR MANAGER
every time the operator presses the deactivated ON/OFF key. To switch off the air system on
SIGMA AIR MANAGER, end remote control mode by pressing the REMOTE key and then
the OFF key.

As well as the handshake function for link monitoring (see 5.1), the following remote control
functions are available:

e Compressed air system OFF/ON function

¢ Toggling between “Manual’”’ and ‘“Automatic”’ modes

¢ (Clock mode ON/OFF

¢ Reset of current alarms, service and warning messages

e Selection and deselection of online compressors (each compressor)
e Selection and deselection of standby compressors (each group)

® Preset of pressure setpoint (in millibar)

® Preset of group sequence
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SEND/RECEIVE control data that have been released are in S5 data block DB34 (see Technical
Description 7_7725_PAGEN_"). Other data may not be written. If other data are written, the
internal data structure will be damaged and function errors or failure of SIGMA AIR
MANAGER will occur. KAESER will not accept any liability or provide any warranty for such
damage.

There is an activating bit for every SEND/RECEIVE function and one or more control bits or
control values. The activating bit activates the respective function and deactivates the
respective local setting (SAM-internal setting). The control bits or control values control the
function itself.

5.3 Process Data

It is a requirement for readout of SIGMA AIR MANAGER'’s process data that
SEND/RECEIVE is activated by selecting the FETCH/WRITE or SEND/RECEIVE
specification. Remote control mode does not have to be activated in order to read out data.
activated

The process data are continually actualized (PLC—cyclic) and contain all the relevant
operational states and process values of SIGMA AIR MANAGER and the online
compressors. The following process data are available:

¢ Process image of SIGMA AIR MANAGER in the S5 data block 31
(see Technical Description 7_7725_PAGEN_¥*)

¢  Process images of the online SIGMA CONTROL compressors in the S5 data
blocks DB64 to DB79 (see Technical Description 7_7000_PASNDRCV_*)
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Annex A: Example STEP5 SEND/RECEIVE Program

The example STEP5 program shown below is a non-binding example for an S5 station. It
contains the most important modules needed to set up an S5-combatible communications
connection with the SEND/RECEIVE specification between an S5 station and SIGMA AIR
MANAGER.

In the example, the content of the S5 station’s DB107 S5 data block (DW 0...15) is read and
then written into SIGMA AIR MANAGER’s DB34 data block. In return, the content of SIGMA
AIR MANAGER’s data block DB31 (DW 0... 119) is copied into the S5 station’s S5 data
block DB106.

OB21&0B22:

:SPA FB249
Name : SYNCHRON
SSNR: KY 0,8
BLGR: KY 0,6
PAFE: MB 40

Kk Kk

i e o ST S

OB1:

:SPA FB10O
Name : SNDRCV

o Kk k Kk

e o L e e A L o e ot o

FB10O

:SPA FB244
Name : SEND
SSNR: Ky 0,8
A-NR: Ky 0,0
ANZW: MW 100
QTYP: KC NN
DBNR: KYy 0,0
QANF : KE +0
QLAE: KF +0
PAFE: MB 42

:SPA FB245
Name : RECEIVE
SSNR: Ky 0,8
A-NR: Ky 0,0
ANZW: MW 110
QTYP: KC NN
DBNR: KYy 0,0
QANF : KE +0
QLAE: KF +0
PAFE: MB 44
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//SEND-DIRECT (SEND)
:UN M141.1//SEND-Job N:Toggle RECEIVE-Job
:SPA FB244//Call FB244

Name : SEND
SSNR: KY 0,8//"0"=Direct parc
A-NR: KY 0,1//Job-Num
ANZW: MW 140//St
QTYP: KC DB//Sou
DBNR: Ky 0,107//
QANF : KF +0//Star ) )
QLAE: KF +16//16DW's to send (DB107 DWO to DW15)
PAFE: MB 50//

number of CP1430TCP

//RECEIVE-DIRECT
:UN MI151.1//REC
:SPA FB245//Ca

Name : SEND

SSNR: Ky 0, 8//"”'1‘1 ~ect pea

A-NR: Ky 0,2//Jo €

ANZW: MW 150//St

QTYP: KC DB//Tar

DBNR: KY 0,106//5Sto ce

QANF : KF +0//Start to store

QLAE: KF +120//120DW’

PAFE: MB 52//

- Kk k Kk

N:Toggle RECEIVE-Job

ngn=R

- rface number of CP1430TCP
configuration)

w113>DWL1%

e o L e o L e o e L L o o S oo e

DB106 (Target-DB in S5 for received SAM-Data):

0: KH = - n
1: KH = jord n+1

118: KH = 0000;//sT
119: KH = 0000;//5T

aword n+118
jord n+119

e o L e o o L e o L o o e

DB107 (Source-DB in S5 for SAM RemoteControl-Data) :

0: KH = 0000;//s

1: KH = 0000;//sS
14: KH = 0000;//SIGMA AIR MANAGER: RemoteControl-Dataword

15: KH = 0000;//s51T rol-Dc

e o Al s e L o o ot o
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Annex B: Example STEP5 FETCH/WRITE Program

The example STEP5 program shown below is a non-binding example for an S5 station. It
contains the most important modules needed to set up an S5-combatible communications
connection with the FETCH/WRITE specification between an S5 station and SIGMA AIR
MANAGER.

In the example, the content of the S5 station’s DB105 S5 data block (DW 0...15) is written
into SIGMA AIR MANAGER'’s DB34 data block. In return, the content of SIGMA AIR
MANAGER’s data block DB31 (DW 0... 119) is read and then written into the S5 station’s S5
data block DB104. In addition, the process data of compressors 1-16 that is stored in SIGMA
AIR MANAGER'’s data blocks DB64...79 is copied into the S5 station’s S5 data blocks
DB120...135.

Y e o L e o L i o
OB21&0B22:

:SPA FB249
Name : SYNCHRON
SSNR: Ky 0,8
BLGR: KY 0,6
PAFE: MB 40

o Kk k Kk

e o L e o L e at o

OB1:
:SPA FB101
Name :FETCHZ

:SPA FB10O
Name : SNDRCV

o kok ok

e i A L e o

131.
100.
100.
131.
100.

T REEE
oN B ON

:UN M 100.1

:SPB =LAl

:L MW 106

:SLW 1

: T MW 106

:L KEF +0

:><F

:SPB =LAl

:UN M 102.0

1= M 102.0

:SPB =LAl

:L KM 00000000 00000001

: T MW 106
LAl :NOP O

o kok ok
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DB 112
KF +31
DW 11
KEF +0
DW 12
KE +120
DW 13
KF +104
DW 15
KEF +0
DW 16
KEF +120;
DW 17
MW 106
KH 0000

i B I e R I e R I SR R T ¥

:SPB =END

KF +0

MB 240
KF +64
MW 236
KF +120
MW 238
MB 240

LOOP:
: KF +8

[ e e e I

:SPB =M107

:L KY 0,106
:SPA =M106
M107:L KY 0,107

:L MB 240

M106:0W
: T MW 242
:B MW 242
:UN -M 0.0
:SPB =KOMP
MW 236
Dw 11
KEF +0
DW 12
KF +64
DW 13
MW 238
DW 15
KEF +0
DW 16
KF +64;
DW 17
MW 236
1
MW 236
MW 238
1
MW 238
MB 240
1
MB 240
KF +15

KOMP :

FHHEHHEHAHRES AR E A

:<=F
:SPB =LOOP
END

o kok ok
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e e o

//SEND-ALL

:SPA FB244//Call FB244 (S5-Standardfunction: SEND)
Name : SEND
SSNR: KY 0,8//"0"=Direc
A-NR: KY 0,0//"0"=nc
ANZW: MW 100//Status
QTYP: KC NN//"NN"
DBNR: KY 0,0//irre
QANEF : KF +0//irre
QLAE: KF +0//irrelev
PAFE: MB 42//

number of CP1430TCP

se interf

barameterising, "8"=B
"O"=ALL-function
MW100)

set on CP1430TCP

//RECEIVE-ALL

:SPA FB245//Call FB245 (S5-Standardfunction: RECEIVE)
Name : RECEIVE
SSNR: KY 0,8//"0"=Direct parameterisin 8 3ase interface
A-NR: KY 0,0//"0"=r ]
ANZW: MW 110//Status
QTYP: KC
DBNR: KY
QANEF': KF
QLAE: KF
PAFE: MB

number of CP1430TCP

W110)
set on CP1430TCP

//SEND-DIRECT (WRITE)
:UN M121.1//WRITE-Job active? Y: sh "A N:Toggle RECEIVE-Job
:SPA FB244//Call FB244 )
Name : SEND
SSNR: Ky 0,8//"0"=Direc
A-NR: KY 0,1//"0"=not
ANZW: MW 120//Statu
QTYP: KC RW//"RW"=Indirect
DBNR: KY 0,112////"0"=nc
QANEF: KF +0//Configur
QLAE: KF +0//irrele
PAFE: MB 46//

number of CP1430TCP
1figuration)

>DB112
this WRITE-Job is DB112

\

nt

//RECEIVE-DIRECT (FETCH)
:UN MI131.1//FETCH
:SPA FB246//Call FB2

Name :FETCH

SSNR: KY 0,8//"0"=Direct parameterising, "8"=

A-NR: KY 0,2////"0"=not t 1, "2"=Job-Number

ANZW: MW 130//Statuswor 3 37

QTYP: KC RW//"RW"=Indir onfiguration ->DB112

DBNR: KY 0,112//"0"=not ed, this FETCH-Job ist DB1l12

QANF : KF +10//Configuration begins at DB112DW10

QLAE: KF 4+0//irreleve

PAFE: MB 48/ /

Y:Refresh "ANZW" N:Toggle RECEIVE-Job
unction: FETCH)

(S5-Standardf

number of CP1430TCP
onfiguration)

U S

e e L e o S
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e L e

KC = 'DB';//SIGMA AIR MANAGER: Source of Datablock to receive is a DB

KY = 000,034;//SIGMA AIR MA Target-DB for Datablock to receive is DB34
KF = +OOOOO,//LIGPL1; ATR MA Start to store Data at DWO (DB34)

KF = +00016; SIGMA AIR MANAGER: 16DW's to store (DB34 DWO to DW
KC = 'DB"//SJ Source of Datablock to send is a DB
KC = 000,105//85: Source-DB for Datablock to s 1 is DB105
KF = +OOOOO,,/55: Start to send Data at DWO (DB105)
KF = 4+00016;//S5: 16DW's to send (DB105 DWO to DW15)
KF = +OOOOO,,/nuL used

O J oUW NP O

9: KF = 4+00000; //not used

10: KC = 'DB';//S5: Source of Datablock to >ive is a DB

11: KY = 000,104;//S5: Target-DB for Datablock to receive is DB104

12: KF = 4+00000;//S5: Start to store Data at DWO (DB104)

13: KF = +00120;//S5: 120DV 5 to store (DB104 0 to DW119)

14: KC = '"DB';//SIGMA end is a DB

Source of Datablock to
~ Datablock to send is DB31

>nd Data at DWO (DB31)

send

15: KC = 000,31;//SIGMA
16: KF = +00000; //SIG] 5 :
17: KF = +00120;//SIGMA AIR MANAGER:

e i A L e o S

DB104 (Target-DB in S5 for received SAM-Data) :

0: KH = 0000;//S n

1: KH = 0000; //SIGMA n+1
118: KH = 0000;//SIGMA AIR MANAGE n+118
119: KH = 0000;//SIGMA AIR MANAGER: n+119

e i A L e o

DB105 (Source-DB in S5 for SAM RemoteControl-Data) :

0: KH = 0000;//SIGMA A RemoteControl-Datawor
1: KH 0000;//SIGMA AIR MANAGER: RemoteControl-Dat

14: KH = 0000;//SIc

5] ATR MANAGE
15: KH = 0000;//SIGM

ATR MANAGER:

e o e o e S

DB120..DB135 (Target-DB in S5 for received Compressor-Data
; Compressor1=DB120..Compressorl16=DB135) :

0: KH = 0000;//s 8 C S S e n

1: KH = 0000;//SIGMA CONTROL: Processdataword n+1
62: KH = 0000;//S CONTROL: n+62
63: KH = 0000;//SIGMA CONTROL: n+63

e o L e a  a o o a aeat 2
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Annex C: Example STEP7 Program

The example STEP7 program shown below is a non-binding example for an S7 300 station.
It contains the most important modules needed to set up a communications connection
between an S7 station and SIGMA AIR MANAGER. The example is an S7 source file. The
code can be inserted into a source file created with the help of the text editor. The
corresponding STEP7 data blocks can then be generated by translation from this source file.

In the example, the content of the S7 station’s DB51 S7 data block (DW 0...15) is copied into
SIGMA AIR MANAGER'’s DB34 S5 data block. In return, the content of SIGMA AIR
MANAGER’s S5 data block DB31 (DW 0...119; SIGMA AIR MANAGER process image) is
copied into the S7 station’s S7 data block DB54 if in SIGMA AIR MANAGER'’s menu option
under

[/main menuj > [settings] > [system] » [communication] > [SEND/RECEIVE]

SAM is entered. If SAM+SC is entered in this menu option, the process images of the SIGMA
CONTROL compressors linked to SIGMA AIR MANAGER are copied sequentially into the
S7 station’s S7 data blocks DB120-DB135 (compr.1 — compr.16).

e o L e o L i o

DATA_BLOCK DB51
TITLE =
VERSION : 0.1

STRUCT
DB_VAR : INT ;
DB_VAR1 : INT ;

DB_VAR14 : INT ;

DB_VAR15 : INT ;

END_STRUCT ;
BEGIN

DB_VAR := 0;

DB_VAR1l := 1;

DB_VAR14 : 14;
DB_VAR15 := 15;
END_DATA_BLOCK

T L B L i o B e S
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e L e

DATA_BLOCK DBS55 //"SR:SAM->S7300_Buffer"
TITLE =

VERSION : 0.1

STRUCT
DB_VAR : INT ;
DB_VAR1 : INT ;

//DB_VAR2 to DB_VAR117 have to be inserted before compiling!!!
DB_VAR118 : INT ;
DB_VAR119 : INT ;
END_STRUCT ;
BEGIN
DB_VAR := 0;
DB_VAR1l := 1;

//DB_VAR2 to DB_

be inserted before compiling!!!

DB_VAR118 := 118;
DB_VAR119
END_DATA_BLOCK

|
=
=
0

~

e o L e o L i o

e i A L e o

SAM->S7300

DATA_BLOCK DB54 //"SFE
TITLE =
VERSION : 0.1

dataSigmaAirMane

STRUCT
DB_VAR : INT ;
DB_VAR1 : INT ;

//DB_VAR2 to DB_

compiling!!!

DB_VAR118 : INT ; //DW118
DB_VAR119 : INT ; //DW119
END_STRUCT ;
BEGIN
DB_VAR := 0;
DB_VAR1l := 1;

//DB_VAR2 to DB_VAR117 have to be inserted before compiling!!!

DB_VAR118 118;
DB_VAR119 := 119;
END_DATA_BLOCK

e o L e a  a o o a aeat 2
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A L B o o T L

DATA_BLOCK DB120
TITLE =
VERSION : 0.1

STRUCT
DB_VAR : INT ;
DB_VARL : INT ;

DB_VAR118 : INT ;
DB_VAR119 : INT ;
END_STRUCT ;

BEGIN
DB_VAR := 0;
DB_VAR1l := 1;
DB_VAR118 := 118;
DB_VAR119 := 119;

END_DATA_ BLOCK

e o L e o L i o

Analog for SigmaControlCompressor_2 to SigmaControlCompressor_16 !!!
DATA_BLOCK DB121
to

DATA_BLOCK DB135
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e e A L e s ot

FUNCTION FC101 VOID // "SR:S7300<->SAM"
TITLE =Communication S7300 <-> SAM

/) T
AUTHOR Tester
FAMILY S7300
NAME FCSNDRCV
VERSION 1.0
VAR_TEMP
Target ANY ;
END_VAR
BEGIN
NETWORK
TITLE =Send Data of DB51, DWO to DW15 into SAM-Receive-Buffer
//
NOP 0; //CALL "AG_SEND"
CALL FC 5 (
ACT
D = C
LADDR = w#16#100,,, Hex 100 < dec 256
SEND = P#DB51.DBX 0.0 WORD 16 //DB51, DWO to DW15
LEN = 32,//16DW’'s = 32Bytes
DONE =M 100.1,
ERROR = M 100.2,
STATUS = MW 102);
/) T
R M 100.0; //Reset ACTIV-BRit
SET ;
A M 100.1; //When DONE-Bit is set —-> Jump to Label "done"
Jc done;
SET ;
A M 100.2; //When ERROR-Bit is set -> Jump to Label "err"
JcC err; //
JU recv; //When ERROR-Bit & DONE-Bit isn't set->continue receiving Data
done: S M 100.0; //set or next Send-Command and
Ju recv; // Jump
err: NOP 1;
S M 100.0; //Set ACTIV-Bit for next try
NETWORK
TITLE =Receive SAM-Data and store it in Buffer-DB55, DWO to DW119
recv: NOP 0; // CALL "AG_RECV"
CALL FC 6 (
ID = 1,//Local-ID (see NetPro!)
LADDR = W#16#100, /Hex 100 -> Dyu 256
RECV = P#DB55.DBX 0.0 WORD 120, //DB55, DWO to DWIL19
NDR =M 110.5,
ERROR =M 110.1,
STATUS = MW 104,
LEN = MW 106);
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NETWORK
TITLE = Route the received data from Buffer_DB

L DB55.DBB 183; //Corresponding Slavenumber in DR91 of Buffer-DB55
JL SPLE;
Ju SPLE; //Slavenumber=0
Ju SPLE; //Slavenumber=1
Ju SAM; //Slavenumber=2 —-> SigmaAirManager
Ju CO1; //Slavenumber=3 -> SigmaControl Compressor 1
Ju C02; //Slavenumber=4 -> SigmaControl Compressor 2
Ju C03; //Slavenumber=5 -> SigmaControl Compressor 3
Ju CO4; //Slavenumber=6 -> SigmaControl Compressor 4
Ju CO5; //Slavenumber=7 -> SigmaControl Compressor 5
Ju C06; //Slavenumber=8 -> SigmaControl Compressor 6
Ju CO07; //Slavenumber=9 -> SigmaControl Compressor 7
Ju C08; //Slavenumber=10-> SigmaControl Compressor 8
Ju C09; //Slavenumber=11-> SigmaControl Compressor 9
Ju C10; //Slavenumber=12-> SigmaControl Compressor 10
Ju Cll; //Slavenumber=13-> SigmaControl Compressor 11
Ju Cl2; //Slavenumber=14-> SigmaControl Compressor 12
Ju Cl13; //Slavenumber=15-> SigmaControl Compressow 13
Ju Cl4; //Slavenumber=16-> SigmaControl Compressor 14
Ju Cl5; //Slavenumber=17-> SigmaControl Compressor 15
Ju Cl6; //Slavenumber=18-> SigmaControl Compressor 16
SPLE: JU CoOMM; // Jump to Label "COMM"
SAM: NOP 0;
L 54; //Set DataBlock DB53 for ProcessdataSigmaAirManager
Ju COMM; // Jump to Label "COMM"
COl: NOP 0;
L 120; //Set DataBlock DB120 for ProcessdataSigmaControlCompressor_1"
Ju COMM; // Jump to Label "COMM"
C0O2: NOP 0;
L 121; //Set DataBlock DB121 for ProcessdataSigmaControlCompressor_2"
Ju COMM; // Jump to Label "COMM"
CO3: NOP 0;
L 122; //Set DataBlock DB122 for ProcessdataSigmaControlCompressor_3"
Ju COMM; // Jump to Label "COMM"
CO4: NOP 0;
L 123; //Set DataBlock DB123 for ProcessdataSigmaControlCompressor_4"
Ju COMM; // Jump to Label "COMM"
CO5: NOP 0;
L 124; //Set DataBlock DB124 for ProcessdataSigmaControlCompressor_5"
Ju COMM; // Jump to Label "COMM"
CO6: NOP 0;
L 125; //Set DataBlock DB125 for ProcessdataSigmaControlCompressor_6"
Ju COMM; // Jump to Label "COMM"
CO7: NOP 0;
L 126; //Set DataBlock DB126 for ProcessdataSigmaControlCompressor_7"
Ju COMM; // Jump to Label "COMM"
CO8: NOP 0;
L 127; //Set DataBlock DB127 for ProcessdataSigmaControlCompressor_8"
Ju COMM; // Jump to Label "COMM"
C09: NOP 0;
L 128; //Set DataBlock DB128 for ProcessdataSigmaControlCompressor_9"
Ju COMM; // Jump to Label "COMM"
Cl0: NOP 0;
L 129; //Set DataBlock DB129 for ProcessdataSigmaControlCompressor_10"
Ju COMM; // Jump to Label "COMM"
Cll: NOP 0;
L 130; //Set DataBlock DB130 for ProcessdataSigmaControlCompressor_11"
Ju COMM; // Jump to Label "COMM"
Cl2: NOP 0;
L 131; //Set DataBlock DB131 for ProcessdataSigmaControlCompressor_12"
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KOMPRESSOREN

Cl13:

Cl4:

Cl5:

Clé6:

COMM:

Ju
NOP

Ju
NOP

Ju
NOP

Ju
NOP

Ju
NOP

HHBEHPEHSE SR

LW 4;
B#lo#2;
LB 1;
B#16#10;
LB 0;
240;

LW 2;
B#lo#84;
LB 6;
0;

LB 7;
LW 8;

//CALL "BLKMOV"

CALL SFC 20 (

SRCBLK
RET_VAL
DSTBLK

END_FUNCTION

sdataSigma

sdataSigma

P#DB55.DBX0.0 BYTE 240, //Source=Buffer DB55
MW 108,
#Target) ; //Destination=DB54 or DB120/121...

e o L e o o L e o L L o oo e
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e i o e o T S

ORGANIZATION_BLOCK OB 1 //"CYCL_EXC"
TITLE = "Main Program Sweep (Cycle)"
VERSION : 0.1

VAR_TEMP
OB1_EV_CLASS : BYTE ; //Bits 0-3 = 1 (Coming event), Bits 4-7 = 1 (Event class 1)
OB1_SCAN_1 : BYTE ; //1 (Cold restart 11 of OB 1), 3 (Scan 2-n of OB 1)
OB1_PRIORITY : BYTE ; //Priority of OB Execution
OB1_OB_NUMBR : BYTE ; //1 (Organization block 1, OBI)
OB1_RESERVED_1 : BYTE ; ved for
OB1_RESERVED_2 : BYTE ; //Reserved for sy
OB1_PREV_CYCLE : INT ; //Cycle time of previous OBl scan (milliseconds)
OB1_MIN_CYCLE : INT ; //Minimum cycle time of OBl (milliseconds)
OB1_MAX_CYCLE : INT ; //Maximum cycle time of OBl (milliseconds)
OB1_DATE_TIME : DATE_AND_TIME ; //Date and time OBl started

END_VAR

BEGIN

NETWORK

TITLE =

stem

stem

CALL FC 101 ; //CALL "SR:S7300<->SAM"

END_ORGANIZATION_BLOCK

e o L e o L ot o

ORGANIZATION_BLOCK OB 100 //"COMPLETE RESTART"
TITLE = "Complete Restart"
VERSION : 0.1

VAR_TEMP
OB100_EV_CLASS : BYTE ; //16#13, Event class 1, Entering event state, Event

logged in diagnostic buffer
OB100_STRTUP : BYTE ; //16#81/82/83/84 Method of startup
OB100_PRIORITY : BYTE ; //Priority of OB Execution
OB100_OB_NUMBR : BYTE ; //100 (Organization block 100, OBR100)
OB100_RESERVED_1 : BYTE ; //Reserved for system
OB100_RESERVED_2 : BYTE ; //Re 7 E stem
OB100_STOP : WORD ; //Event that caused CPU to stop (l6#4xxx)
OB100_STRT_INFO : DWORD ; //Information on how system started
OB100_DATE_TIME : DATE_AND_TIME ; //Date and time OR100 started

END_VAR

BEGIN

NETWORK

TITLE =

SET ;
= M 100.0; //Set ACTIV-Bit once for the first Send-Command

END_ORGANIZATION_BLOCK

e T L i e o
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